Forums

Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
programming bootloader on one inch of goodness
January 21, 2013
8:16 pm
Avatar
fmezzoiuso@roadrunner.com
New Member
Members
Forum Posts: 1
Member Since:
January 21, 2013
sp_UserOfflineSmall Offline

If i understand correctly, i can use the arduino ide, and the USBtinyISP AVR Programmer Kit from adafruit using the 6pin isp header to program bootloader on chip..
Arduino ide> choose board(Duemilanove,atmega328), choose usbtinyisp> burn bootloader...
The other method would be soldering headers on one inch of goodness board using ftdi and burn bootloader form there...???? Please clarify...just learning

Frank

January 23, 2013
7:41 pm
Avatar
dramob
Member
Members
Forum Posts: 3
Member Since:
January 10, 2013
sp_UserOfflineSmall Offline

I don't think using the ftdi and Arduino IDE will allow you to upload the bootloader directly. To use the ISP you will still need a reliable way to connect the 6 pins necessary to program as well as short the DTR pin to RST or use tweezers to SHORT the .1uF capacitor, FOR THE ENTIRE UPLOAD PROCESS! If using the USBtinyISP, then the light will remain red until the bootloader process is finished. You are correct in that selecting the board and bootloader in the Arduino IDE will allow you to burn the bootloader.

The FTDI headers will allow you to upload sketches with the IDE which is different than burning the bootloader. If you don't have a need to burn the bootloader, then using the FTDI is the way to go.

Hope this helps,
D

September 21, 2013
4:35 pm
Avatar
howiewok
New Member
Members
Forum Posts: 2
Member Since:
September 21, 2013
sp_UserOfflineSmall Offline

I just received the OneSquareInch and of course, I can't seem to upload sketches to it. I looked through this forum but didn't find the "answer". I am using a MacBook Pro running OSX 10.8, I have Arduino software 1.5.3, and I tried using both an Arduino UNO Rev.2 , and a TinyISP from Adafruit. All I can get so far is what appears to be a "reset" but no code uploads, and I get lots of error messages from the Arduino application. I have shorted the capacitor near the reset pin. I have the QneSquareInch hooked up to the 6 pin connector on the Uno, except that RESET is tied to pin 10 on the Arduino.

First I uploaded the ArduinoISP version 04m3 sketch to the Uno, then in the Arduino application I opened the Blink sketch, and selected Tools:Board:Duemilanove or Diciemila, Tools:Programmer:Arduino as ISP, and then File:Upload Using Programmer.

I get various errors depending on some seemingly random bits . . .

I also tried to "Burn Bootloader" but had no success with that either.

---> any suggestions anyone?

Howie
925-787-7848
howie@howietronics.com

October 9, 2017
3:22 pm
Avatar
mover55
New Member
Members
Forum Posts: 1
Member Since:
October 9, 2017
sp_UserOfflineSmall Offline

Thank for your explanations!

pożyczka bez bik

November 22, 2017
6:41 am
Avatar
mikanox
Member
Members
Forum Posts: 18
Member Since:
October 20, 2017
sp_UserOfflineSmall Offline

Do you have any suggestions?
http://carbuying.co.uk

Forum Timezone: America/New_York

Most Users Ever Online: 24

Currently Online:
2 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

mikanox: 18

balam: 7

rakitik23: 7

xavier: 4

Atymkow: 4

dako62: 4

Member Stats:

Guest Posters: 1

Members: 2167

Moderators: 0

Admins: 1

Forum Stats:

Groups: 1

Forums: 8

Topics: 103

Posts: 289

Newest Members:

DanielDI, Mopvcn, Gregoryst, JosephSkela, MosCrorbdax, Jeffreygok

Administrators: Jeremy: 41